4月 122012
 

cacti-0.8.8终于发布了,修复了很多bug,而且集成了PIA,以后就估计就没有PIA这个说法了。

Release Notes – 0.8.8

Important Notices

Plugin Architecture is now part of Cacti
Changelog

 

    • bug#0002056: un-initialized datetime used for host status (was: Zero length string != NULL)
    • bug#0002081: In Graph Management, search display graph title breaks when using pattern symbol “/”
    • bug#0002132: need to include pa.sql with the 0.8.7i and future releases
    • bug#0002134: rebuild_poller_cache.php –host-id deletes table poller_item completely
    • bug#0002141: cacti.sql missing BTREE PRIMARY KEY for poller_output
    • bug#0002146: Utilities -> View Log File -> refresh does not work
    • bug#0002150: usort_data_query_index() is broken -> graph order for hosts with data query sort option fails
    • bug#0002151: When building HTML forms with sub_checkbox on_change parameter is not used
    • bug#0002152: Issue with filter on graphs_new.php

  • bug#0002153: Cant search for patterns containing a forward-slash
  • bug#0002156: CDEF strings are not escaped before passed to rrdtool command
  • bug#0002158: Minor changes to grammar of displayed messages
  • bug#0002165: Using data input field in data source name (related to 2079 in 0.8.7i)
  • bug#0002167: New poller hook poller_finishing
  • bug#0002172: structure_rra_paths.php does not handle disabled data sources
  • bug#0002174: poller_item.host_id has wrong type
  • bug#0002178: typo in include/global_form.php: Mimimum -> Minimum
  • bug#0002181: session_unregister (use in functions.php) doesn’t exist anymore in PHP 5.4
  • bug#0002182: When there is no suitable (unique) index, graphs are not shown in data query ordering on host leafs
  • bug#0002189: Proper graph hooks
  • bug#0002191: Refresh issues
  • bug#0002194: changing data query XML does not propagate to existing data sources
  • bug: Fix input validation on cli/api_device.php
  • bug: Fix issue with data source template associate command line script inserting incorrect rra information
  • bug: Fix minor display issue on data source pages
  • bug: Fix minor issue with counting items in the poller_output table
  • bug: Graph settings and settings check boxes do not allow unchecking to be saved
  • bug: Fix minor issue with plugin library caused by non-session
  • bug: Fix SQL error on data input save for non-templated graphs
  • bug: user_log index added to increase performance
  • feature: Merge Plugin Architecture into Cacti
  • feature: Added index to data_template_data to increase performance

安装好之后就直接看到到了Plugin Management。

初步使用不错,在导入模版的时候发现提示

 Importing template Error: XML: Cacti version does not exist

在cacti论坛里找到这个解决方法,原来这个是bug,并且已经提交,并修复了。

http://bugs.cacti.net/view.php?id=2207

临时的解决办法就是

vi include/global_arrays.php
$hash_version_codes = array(
"0.8.4" => "0000",
"0.8.5" => "0001",
"0.8.5a" => "0002",
"0.8.6" => "0003",
"0.8.6a" => "0004",
"0.8.6b" => "0005",
"0.8.6c" => "0006",
"0.8.6d" => "0007",
"0.8.6e" => "0008",
"0.8.6f" => "0009",
"0.8.6g" => "0010",
"0.8.6h" => "0011",
"0.8.6i" => "0012",
"0.8.6j" => "0013",
"0.8.7" => "0014",
"0.8.7a" => "0015",
"0.8.7b" => "0016",
"0.8.7c" => "0017",
"0.8.7d" => "0018",
"0.8.7e" => "0019",
"0.8.7f" => "0020",
"0.8.7g" => "0021",
"0.8.7h" => "0022",
"0.8.7i" => "0023"
);

找到这里,在这里添加一个

"0.8.8"  => "0024"

并在”0.8.7i” => “0023”后加一个,
修改好后为

$hash_version_codes = array(
"0.8.4" => "0000",
"0.8.5" => "0001",
"0.8.5a" => "0002",
"0.8.6" => "0003",
"0.8.6a" => "0004",
"0.8.6b" => "0005",
"0.8.6c" => "0006",
"0.8.6d" => "0007",
"0.8.6e" => "0008",
"0.8.6f" => "0009",
"0.8.6g" => "0010",
"0.8.6h" => "0011",
"0.8.6i" => "0012",
"0.8.6j" => "0013",
"0.8.7" => "0014",
"0.8.7a" => "0015",
"0.8.7b" => "0016",
"0.8.7c" => "0017",
"0.8.7d" => "0018",
"0.8.7e" => "0019",
"0.8.7f" => "0020",
"0.8.7g" => "0021",
"0.8.7h" => "0022",
"0.8.7i" => "0023",
"0.8.8" => "0024"
);

这样就可以解决了,别的还在测试中。

打赏
 Posted by at 下午 3:02

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)